Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid storefronts are not available at the moment
Incident Report for Ecwid
Resolved
We have identified and tackled the problem. Ecwid Control Panels and storefronts are available again.

All your store data is intact. Please accept our sincere apologies for the outage.
Posted Nov 20, 2017 - 07:29 UTC
Investigating
At the moment Ecwid storefronts and Control Panels are not available. Our development team has found the source of this issue and is in the process of restoring the service.

Please accept our sincere apologies. All your store data will be kept intact and we will be posting updates here.
Posted Nov 20, 2017 - 07:18 UTC