Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Approximately 15% of Ecwid stores are temporarily inaccessible
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted Jun 20, 2015 - 23:11 UTC
Update
We have restored the service, all Ecwid stores are now up and running. All data (products, orders, store settings etc) is safe.
15% of Ecwid stores were inaccessible for approximately 9 minutes.

We’re sorry for the inconvenience. Please, accept our apologies for the downtime.
Posted Jun 20, 2015 - 23:11 UTC
Investigating
Ecwid is having troubles with one of the servers: about 15% of the storefronts and control panels may experience short periods of being inaccessible. Our engineers are doing their best to fix this ASAP.

All your data will be kept intact and safe. Please, accept our apologies for these troubles. We will be publishing updates here.
Posted Jun 20, 2015 - 22:58 UTC