Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid storefronts are not available on Wix websites
Incident Report for Ecwid
Resolved
We have restored the service, all Ecwid stores are now up and running. We continue investigating this incident to find out what led to this problem.
Posted Apr 19, 2016 - 12:45 UTC
Investigating
At the moment Ecwid storefronts added on Wix websites are not available. Our development team has found the source of this issue and is in the process of restoring the service.

Estimated time of completing the restoration is 15 minutes.

We are very sorry for these troubles. All your store data will be kept intact and we will be posting updates here.
Posted Apr 19, 2016 - 12:43 UTC