Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid Help Center is unavailable
Incident Report for Ecwid
Resolved
Ecwid help center services have been restored and they are available now.

Please accept our sincere apologies for the issue.
Posted Aug 16, 2015 - 11:37 UTC
Identified
At the moment Ecwid Help Center and contact form are unavailable. It happened due to a failure at Desk.com service.

Feel free to contact us and ask your questions on our forum and Facebook page while Desk is working on restoring the service.

All Ecwid storefronts are working as usual and your store data is intact. Please accept our sincere apologies.
Posted Aug 16, 2015 - 11:19 UTC