Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid storefronts are not available to some users.
Incident Report for Ecwid
Resolved
Our engineers have fixed the issue — all Ecwid storefronts are now up and running and working as usual.

Your store data is safe and intact. We are very sorry for the temporary downtime.
Posted Aug 11, 2017 - 11:59 UTC
Identified
At the moment 19.21% of Ecwid storefronts are not available. Our development team has found the source of this issue and is in the process of restoring the service.

Estimated time of completing the restoration is 10 minutes.

Please accept our sincere apologies. All your store data will be kept intact and we will be posting updates here.
Posted Aug 11, 2017 - 11:41 UTC