Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid storefronts and Control Panels are not available for 18% of users
Incident Report for Ecwid
Resolved
The issue is fixed - all Ecwid stores and Control panels are loading fine now.
Really sorry about the downtime!
Posted Feb 22, 2017 - 12:51 UTC
Investigating
Ecwid storefronts and Control Panels are not available for 18% of users

At the moment 18% of Ecwid storefronts and Control Panels are not available. Our development team has found the source of this issue and is in the process of restoring the service.

Estimated time of completing the restoration is 15 minutes.

Please accept our sincere apologies. All your store data will be kept intact and we will be posting updates here.
Posted Feb 22, 2017 - 12:40 UTC