Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Possible sporadic issues with Ecwid Availability
Incident Report for Ecwid
Resolved
The problem has been resolved. Our developers have fixed the trouble.
Posted Jun 22, 2016 - 13:54 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 22, 2016 - 13:23 UTC
Investigating
At the moment there can be sporadic issues with the ability to login to Ecwid Control Panel. All data including products, orders, store settings will be kept safe and intact. We'll be posting updates here.

ETA is 30 minutes.

We are sorry for the troubles.
Posted Jun 22, 2016 - 13:06 UTC