Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid storefronts are not available to 7% of users
Incident Report for Ecwid
Resolved
All Ecwid stores are now up and running and working as usual.

We are very sorry for the temporary downtime.
Posted Jun 12, 2017 - 14:51 UTC
Monitoring
A fix has been implemented and we are monitoring the results
Posted Jun 12, 2017 - 14:33 UTC
Identified
We have identified the source of the issue and are in the process of rolling out a fix. ETA — 20 minutes.
Posted Jun 12, 2017 - 14:11 UTC
Investigating
Ecwid storefronts and Control Panels are not available for 7% of users

At the moment 7% of Ecwid storefronts and Control Panels are not available. Our development team has found the source of this issue and is in the process of restoring the service.

Estimated time of completing the restoration is 30 minutes.

Please accept our sincere apologies. All your store data will be kept intact and we will be posting updates here.
Posted Jun 12, 2017 - 13:44 UTC