Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid storefronts and Ecwid admin panels are slowly loading for 40% users
Incident Report for Ecwid
Resolved
Our engineers have fixed the issue with slow loading. All Ecwid Storefronts and Control Panels are loading normally now.

All your data will be kept intact and safe. Please, accept our apologies for this issue.
Posted Jun 15, 2018 - 15:53 UTC
Monitoring
Our engineers found the reason for the slow loading and have implemented a fix — all Ecwid Storefronts and Control Panels are loading normally now.

We are continuing to monitor the results and sincerely apologize for the downtime.
Posted Jun 15, 2018 - 14:29 UTC
Update
We are continuing to investigate the issue with the slow loading of some Ecwid Storefronts and Control Panels.

No ETA is available for a resolution at this time. We will provide an update as soon as we have new information.
Posted Jun 15, 2018 - 13:11 UTC
Investigating
Ecwid is having troubles with one of the servers: storefronts and control panels are slowly loading for 40% users. Our engineers are currently investigating the issue.

All your data will be kept intact and safe. Please, accept our apologies for this downtime. We will be publishing updates here.
Posted Jun 15, 2018 - 11:21 UTC
This incident affected: Storefront and Admin.