Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Some labels in Ecwid control panels display incorrectly
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted Sep 14, 2017 - 00:10 UTC
Monitoring
Rolling out the fix has taken a few minutes more — we are very sorry about that!

At the moment, the issue has been resolved: all control panels appear as they should and you can use them as usual now.

Your store data, products, and settings are safe and intact. We are terribly sorry for the temporary downtime!
Posted Sep 13, 2017 - 22:51 UTC
Identified
The developers have found the root of the issue and are currently rolling out the fix. ETA is 5 minutes.
Posted Sep 13, 2017 - 22:37 UTC
Investigating
At the moment, some labels in Ecwid control panels display incorrectly: menu items, buttons names, etc., display internal names of the labels instead of their translations. Our engineers are looking into the problem to find out what has gone wrong and roll out a fix as soon as possible.

At the moment, as a possible temporary solution, please attempt to refresh the control panel page a few times to resolve this, as most customers have had luck doing so to correct the issue. Please, mind that you may need to attempt to clear your web browser's cache additionally for further resolution of the issue. Here's an article which describes how to do this in all major browsers:

https://kb.iu.edu/d/ahic

We sincerely apologize for any trouble caused by this issue! All your store data will be kept intact and we will be posting updates here.
Posted Sep 13, 2017 - 22:28 UTC