Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid contact forms are unavailable
Incident Report for Ecwid
Resolved
All Help Center services are fully operational now, so please feel free to contact us if you have any questions about Ecwid here: https://help.ecwid.com/customer/portal/emails/new
Posted Sep 23, 2015 - 07:19 UTC
Update
The contact form in Ecwid control panel and in Ecwid help center is back online, however Desk.com is undergoing a service maintenance on it, so it may be inaccessible during some periods of time.

We are monitoring situation closely and will provide an update to the status of this situation here.
Thank you for your continued patience.
Posted Sep 23, 2015 - 04:20 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 22, 2015 - 19:09 UTC
Investigating
At the moment contact forms in our Help Сenter and in Ecwid control panels (“Get help” drop down) provided by Desk.com are unavailable. The error is due to a failure at Desk.com service.

Feel free to contact us and ask your questions on our forum and Facebook page while Desk is working on restoring the service.

All Ecwid storefronts are working as usual and your store data is intact. Please accept our sincere apologies.
Posted Sep 22, 2015 - 19:07 UTC