Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Service is unreachable for 50% of users
Incident Report for Ecwid
Resolved
We have restored the service, all Ecwid stores are now up and running. All data (products, orders, store settings etc) is safe.

We are very sorry for this downtime.
Posted Jan 29, 2016 - 13:56 UTC
Update
We are still having troubles with the servers. Our engineers are fixing the services. Estimated time of completing the restoration is 15 minutes.
All your data will be kept intact and safe.
We are very sorry for this downtime.
Posted Jan 29, 2016 - 12:51 UTC
Identified
Ecwid is having troubles with the servers: about 50% of the storefronts and control panels are not loading or may be loading slowly. Our engineers are already fixing the services.

All your data will be kept intact and safe. Please, accept our apologies for this downtime. We will be publishing updates here.
Posted Jan 29, 2016 - 12:28 UTC