Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

20% stores have issues with checkout and orders
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted Nov 17, 2017 - 21:37 UTC
Investigating
We are currently investigating this issue.
Posted Nov 17, 2017 - 19:16 UTC
Update
At the moment 20% of merchants may experience issues with accepting payments and processing orders. Our development team is investigating the problem.

All your data will be kept intact and safe. Please, accept our apologies for these troubles. We will be publishing updates here.
Posted Nov 17, 2017 - 16:22 UTC
Identified
At the moment 8% of merchants may experience downgraded performance resulting in slow loading of Control Panels and storefronts. Our development team has found the source of this issue and is in the process of rolling out a fix.

Please accept our sincere apologies. All your store data will be kept intact and we will be posting updates here.
Posted Nov 17, 2017 - 14:36 UTC