Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Service is unreachable for 20% of users
Incident Report for Ecwid
Resolved
We have fully restored the service, all Ecwid storefront and control panels are up and running. All data (products, orders, store settings etc) is safe.

Please, accept our apologies for the downtime.
Posted May 27, 2015 - 07:53 UTC
Monitoring
Our engineers are still working on restoring the services. 10% of users may be experiencing slow loading of the storefront and control panel. We expect the services to be fully restored in 15 minutes.
Posted May 27, 2015 - 07:48 UTC
Investigating
Ecwid is having troubles with the servers: about 20% of the storefronts and control panels are not loading or may be loading slowly. Our engineers are already fixing the services.

All your data will be kept intact and safe. Please, accept our apologies for this downtime. We will be publishing updates here.
Posted May 27, 2015 - 07:39 UTC