Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Our forums are unavailable
Incident Report for Ecwid
Resolved
Ecwid forums are fully operational. Please accept our sincere apologies for this issue.
Posted Nov 16, 2015 - 17:40 UTC
Investigating
We are sorry to inform you that Ecwid forums (http://www.ecwid.com/forums/) are unavailable at the moment.

All your Ecwid storefronts, Ecwid control panel and store data are intact and working as usual.

We will be providing updates on this issue here, please accept our apologies for this issue.
Posted Nov 16, 2015 - 17:29 UTC