Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Delay in receiving admin and customer notifications
Incident Report for Ecwid
Resolved
The issue has been resolved. Admin and customer email notifications are delivered without any delay.

Please, accept our sincere apologies for this problem.
Posted May 26, 2016 - 11:10 UTC
Monitoring
The system issues have been resolved. Our developers are continuing to monitor the situation.
Posted May 26, 2016 - 10:42 UTC
Investigating
We are having issues with admin and customer email notifications. They are currently delivered with a delay of about 10 - 15 minutes. These delayed notifications are now queued. No mail has been lost and all queued mail will be delivered in the order it was queued. We are terribly sorry about this.

The new orders appear in your Ecwid Control Panel with no delay, so please check the "My Sales" section for the incoming orders.

The orders can also be seen instantly after they are placed with incoming push notifications through our apps for mobile devices: iOS and Android.

Our engineers are investigating the problem right now. Please, accept our sincere apologies for the troubles.
Posted May 26, 2016 - 10:22 UTC