Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

PayPal is having Issues
Incident Report for Ecwid
Resolved
PayPal has just reported that the issue has been resolved and all PayPal services are working normally.

In other words, now all the payments are processed as usual.
Posted Aug 16, 2016 - 21:05 UTC
Investigating
This concerns our customers who use PayPal as the payment method in their stores. To check out if you're using any of the PayPal payment methods, go to the Ecwid Control Panel → Settings → Payment and see if any of PayPal payment options is enabled.

PayPal has notified us that they are experiencing a system issue which may be affecting PayPal APIs on the PayPal Live Site. PayPal are promising to give updates within 15-30 minutes, we will post their updates here.

There may be issues with accepting payments via PayPal so you may wish to use some other payment option.

All your store data is safe and secure. We will post an update as soon as PayPal starts to work as usual.
Posted Aug 16, 2016 - 20:39 UTC