Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid Forums are not available
Incident Report for Ecwid
Resolved
We’re back! Forum and other site services are working fine.
Posted Feb 01, 2016 - 21:01 UTC
Investigating
Ecwid forum website is having problems and unavailable for all our users.

No worries about your Ecwid store: all your store data is absolutely intact and Ecwid users are able to access their Ecwid control panel as usual. And the storefronts are available for visitors. This issue affects only our Forums website.

Ecwid users are always able to contact the support end engineering team via Facebook and Twitter.

We are very sorry for this downtime. Our engineers are working on restoring these services.
Posted Feb 01, 2016 - 20:53 UTC