Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

USPS services are temporarily unavailable
Incident Report for Ecwid
Resolved
USPS team fixed their API and it's working fine now. We are sorry for the difficulties.

USPS Shipping Method is now Online and your customers are able to get live rates from it.
You no longer need to use the workaround mentioned in the previous update.

USPS API went offline at 2016-06-23 07:37 UTC then came back online at 2016-06-23 09:27 UTC.
To learn what time it is for your location, please refer here http://www.worldtimebuddy.com/?qm=1&lid=100,524901,8,5&h=8&date=2016-6-23&sln=0.5-2.5

All your Ecwid store data is safe and intact.
Posted Jun 23, 2016 - 09:51 UTC
Update
How to temporarily disable USPS shipping method:
- Go to Ecwid control panel > Settings > Shipping - press "Disable" next to USPS shipping method
How to set up alternative shipping methods while USPS is down:
- Go to Ecwid control panel > Settings > Shipping: press on New shipping method, choose Flat rate or Custom table (for the instructions on setting this methods please refer to this article - https://support.ecwid.com/hc/en-us/articles/207100479-Shipping#Flatrate)
Posted Jun 23, 2016 - 08:18 UTC
Investigating
The status is only meant for the Ecwid store owners who are using USPS shipping method to receive shipping rates online.

USPS is having troubles at this moment. All the e-commerce solutions (not only Ecwid) which have an integration with USPS currently can not get live rates from it.

Please check the status of the service on this website: http://www.shippingapimonitor.com/

If you are using USPS carrier-calculated shipping method only, your customers are now getting ‘Sorry, we do not ship to this location’, or if you are using multiple shipping methods, USPS is not offered on checkout.

We are very sorry that you are facing this and we hope that USPS team will fix the issue soon. We will keep you updated on their progress.

Please note that your storefront is totally available, your customers are able to view products and add them to the shopping bag.

We suggest you using one of the following temporary workarounds to provide your customers correct shipping rates in the meantime:

- You can consider disabling USPS method temporarily
- If USPS is the only shipping method that you use in your Ecwid store, you can create any other shipping method in your store. For example, you may create a Flat Rate shipping method or a Custom Table to ensure your customers will receive proper shipping rates.

Note: the issue on USPS servers does not anyhow affect Ecwid data, stores data (orders, products, customers etc) - all your data will be safe. The service interruption only affects carrier-calculated USPS shipping method.
Posted Jun 23, 2016 - 08:08 UTC