Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Global issues with Internet connection
Incident Report for Ecwid
Resolved
Dyn.com has just reported that the Internet connection has been restored.

All Ecwid data including products, orders and stores settings is intact. Admin and customer email notifications are delivered without any delay. Your customers received the emails too.

We are sorry for the troubles caused by that.
Posted Oct 21, 2016 - 14:14 UTC
Investigating
Today since 11:10 UTC there have been sporadic issues with Internet connection all over the world as there are troubles with one of the biggest DNS providers Dyn.com. More details on their Status page.

It means that plenty of websites and online services may be unreachable. If you can't open some websites most likely this is it. In this case try using your mobile Internet or connect via another internet provider.

How it relates to Ecwid:

- All data including products, orders, stores settings are kept safe and intact, no worries.
- Email notifications (e.g. about new orders ) may be delayed. If you don't receive a notification about an order, it means it is queued and will be deliver a bit later. The new orders appear in your Ecwid Control Panel on time, so check the "My Sales" section for the incoming orders.
- Your customers may not access your Ecwid store. If you receive any complaints about that, ask them to open the stores via another internet connection.

We are monitoring the situation. Again, all your store data is safe and secure. We will be posting updates here.
Posted Oct 21, 2016 - 12:54 UTC