Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid storefronts are not available to 16% of users
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted Sep 21, 2016 - 21:16 UTC
Monitoring
We have restored the service, all Ecwid stores are now up and running. We continue investigating this incident to find out what led to the problem.
Posted Sep 21, 2016 - 18:46 UTC
Identified
We've identified the source of the issue and working on the fix now.
Posted Sep 21, 2016 - 18:16 UTC
Investigating
At the moment 16% of Ecwid storefronts are not available. Our development team has found the source of this issue and is in the process of restoring the service.

Estimated time of completing the restoration is 30 minutes.

Please accept our sincere apologies. All your store data will be kept intact and we will be posting updates here.
Posted Sep 21, 2016 - 18:08 UTC