Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid Help Center is unavailable
Incident Report for Ecwid
Resolved
Our Help Center is finally back on!

We are still and always will be available in the "Get Help" form in your Ecwid Control Panel.
Posted Jan 29, 2016 - 14:20 UTC
Update
There are still problems on the side of our service provider Desk.com.

Look below to find the ways of contacting us for now and reaching Knowledge Base if you need instructions, please.

We are very sorry for the trouble.
Posted Jan 29, 2016 - 10:15 UTC
Monitoring
We now have to disable the Help Center until Desk.com fixes all the issues with the side services.

Meanwhile you can refer to the articles in our old Knowledge Base if you need instructions from them.

We are still and always will be available in a Live Chat , Email and the "Get Help" form in your Ecwid Control Panel.

Also feel free to contact us at our Forums and Facebook page

We are very sorry that you are still facing these troubles.
Posted Jan 28, 2016 - 23:05 UTC
Update
Our Help Center is finally back on!

We are waiting for Desk.com to revive all the rest services. Look below to find the ways of contacting us for now, please.
Posted Jan 28, 2016 - 21:30 UTC
Update
We implemented a temporary fix for our "Get help" form in the Ecwid Control Panels.

The form is now loaded from our servers instead of the servers of Desk.com which are unfortunately still down.

Please contact us through this form for any support you need.

You can also keep using the other available channels like Live Chat or Email

And of course, feel free to contact us at our Forums and Facebook page

We are terribly sorry for the trouble.
Posted Jan 28, 2016 - 19:30 UTC
Update
There are still problems on the side of our service provider Desk.com.

Right now our Help Center is unavailable due to these issues. "Get Help" form is also still blank.

Desk.com developers are doing their best to fix all the troubles with their service right now.

We are still here to help, so please contact us in a Live Chat or send an Email to us We'll be glad to assist!

You can also contact us at our Forums and Facebook page

Please forgive us for this downtime, we are very sorry.
Posted Jan 28, 2016 - 16:51 UTC
Update
Our "Get Help" form is still unavailable. We are very sorry about this.

Our service provider Desk.com are still working on this issue to fix it as soon as possible.

Should you need any help from our Customer Care team, please contact us at our Forums and Facebook page

We'll be glad to assist you.
Posted Jan 28, 2016 - 15:47 UTC
Identified
Ecwid's Get Help form may be temporarily unavailable during the day due to a failure at our service provider, Desk.com.

We are still here to support you, though, and will be glad to help. Please contact us at our Forums and Facebook page

All Ecwid storefronts are working as usual and your store data is intact. Please accept our sincere apologies.
Posted Jan 28, 2016 - 07:43 UTC
Investigating
At the moment contact forms in our Help Сenter and in Ecwid control panels (“Get help” drop down) provided by Desk.com are unavailable. The error is due to a failure at Desk.com service.

Feel free to contact us and ask your questions on our Forums and Facebook page while Desk is working on restoring the service.

All Ecwid storefronts are working as usual and your store data is intact. Please accept our sincere apologies.
Posted Jan 28, 2016 - 06:45 UTC