Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Some orders may not show in My sales section
Incident Report for Ecwid
Resolved
The problem has been fixed. All orders display in My sales section now.
Posted Feb 16, 2017 - 10:59 UTC
Identified
The storefronts and control panels are fully operational, yet some recent orders may not show in My sales section. All your sales data is intact and you'll see the orders in My sales section when it is fixed. We are working on it urgently.

In the meantime, you can see the order details in these ways:

1. Search for the order number in My sales section or filter the orders by date.
2. The full list of orders is showing in the mobile App. Download the App from the control panel here: https://my.ecwid.com/cp/CP.html?#mobile
3. See orders details in the email notifications. Here is how to set them up: https://support.ecwid.com/hc/en-us/articles/207100529

We are very sorry for the trouble. We’ll post updates here.
Posted Feb 16, 2017 - 10:31 UTC