Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

7% of Ecwid Stores are loading slowly
Incident Report for Ecwid
Resolved
All Ecwid stores are now up and running. Please contact us if you notice any issue: https://help.ecwid.com/customer/portal/emails/new
Posted Feb 08, 2016 - 20:32 UTC
Monitoring
We have restored the service, all Ecwid stores are now up and running. We continue investigating this incident to find out what led to this problem.
Posted Feb 08, 2016 - 17:39 UTC
Investigating
Ecwid is having troubles with one of the servers: about 7% of the storefronts and control panels may be loading slowly. Our engineers are already fixing the services.

All your data will be kept intact and safe. Please, accept our apologies for these troubles. We will be publishing updates here.
Posted Feb 08, 2016 - 17:21 UTC