Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Scheduled maintenance of Ecwid databases
Incident Report for Ecwid
Resolved
The maintenance of Ecwid databases is completed. All Ecwid storefronts and control panels are up and running. All data (products, orders, your store settings, etc) is safe and sound.
Posted Feb 10, 2016 - 11:24 UTC
Monitoring
We’re having a scheduled maintenance during which our customers might experience degraded performance of Ecwid Control Panels and storefronts.
We apologize for the troubles caused. Our specialists will be monitoring the system. All data including products, orders, stores settings will be kept safe and intact. We will be posting updates here.
Posted Feb 10, 2016 - 09:51 UTC