Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid storefronts are not available to 6% of users
Incident Report for Ecwid
Resolved
We have restored the service, all Ecwid stores are now up and running. We continue investigating this incident to find out what led to such a problem.
Posted Jun 29, 2015 - 17:53 UTC
Identified
At the moment 6% of Ecwid storefronts are not available. Our development team has found the source of this issue and is in the process of restoring the service.

Estimated time of completing the restoration is 10 minutes.

Please accept our sincere apologies. All your store data will be kept intact and we will be posting updates here.
Posted Jun 29, 2015 - 17:45 UTC