Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Issue with PayPal Express Checkout
Incident Report for Ecwid
Resolved
We have resolved the issue. PayPal Express Checkout works fine now.
Posted Jun 05, 2018 - 14:42 UTC
Identified
We have found the source of the issue and are working on the fix.
Posted Jun 05, 2018 - 14:05 UTC
Update
We keep investigating the issue. It is more likely to happen to customers who select the USA or Canada as their shipping address at checkout. If you sell to these countries, we recommend that you disable PayPal Express Checkout until the issue is resolved.
We'll post updates here.
Posted Jun 05, 2018 - 08:26 UTC
Investigating
This status concerns merchants who use PayPal Express Checkout to accept payments in their stores.

When customers use PayPal Express Checkout to pay for orders, they may see “Things don’t appear to be working at the moment” error. We are working with PayPal to find out why it happens. If you see this error in your store, consider disabling PayPal Express Checkout method temporarily and use other payment methods. Please, accept our apologies for the trouble. We will post updates here.

Note: the issue does not anyhow affect the store data (orders, products, customers, etc.). All your store data is safe and intact.
Posted Jun 05, 2018 - 02:07 UTC
This incident affected: Checkout.