Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

6% of Ecwid Stores are loading slowly
Incident Report for Ecwid
Resolved
This issue has been resolved. All Ecwid storefronts and control panels are working as usual. All your data is intact. We are vert sorry for any inconvenience caused by this incident.
Posted Jul 22, 2015 - 09:57 UTC
Monitoring
We have applied a fix for this issue and our engineers are monitoring the situation at the moment.
Posted Jul 22, 2015 - 09:34 UTC
Update
Our engineers are still looking into available solutions for this issue. The approximate ETA is 1 (one) hour. We are terribly sorry for the inconvenience.
Posted Jul 22, 2015 - 09:18 UTC
Identified
We have found the source of the issue and our engineers are working on a solution at the moment.
Posted Jul 22, 2015 - 08:53 UTC
Update
Our engineers are still working on a fix for this issue. We are very sorry for any inconvenience caused by it.
Posted Jul 22, 2015 - 08:32 UTC
Investigating
Ecwid is having troubles with one of the servers: about 6% of the storefronts and control panels may be loading slowly. Our engineers are already fixing the services.

All your data will be kept intact and safe. Please, accept our apologies for these troubles. We will be publishing updates here.
Posted Jul 22, 2015 - 08:18 UTC