Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Incorrect orders display in Ecwid control panels
Incident Report for Ecwid
Resolved
The service has been completely restored, all the orders are displayed correctly in stores' control panels. All data (products, orders, store settings etc) is safe.

We are sorry for temporary inconvenience that might had been caused by this.
Posted Jun 24, 2015 - 06:54 UTC
Monitoring
Our engineers are working on restoring the service.
Posted Jun 23, 2015 - 18:42 UTC
Identified
We received reports that for some Ecwid users the orders in their Ecwid control panels are displayed incorrectly. For example, some of the orders are missing or the orders can be displayed in non consecutive order.

This issue affects about 3% of Ecwid users and it only influences how the orders are displayed in Ecwid control panels. All your store data, including the orders, will be kept intact.

Our engineers are working on fixing the display of the orders in Ecwid control panels at the moment and we will be posting updates here. We are sorry for any inconvenience. Thank you for your patience.
Posted Jun 23, 2015 - 16:28 UTC