Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid storefronts and control panels are not available for 14% of users
Incident Report for Ecwid
Resolved
The issue has been resolved - all Ecwid storefronts are now loading fine.

Please, forgive us for the downtime.
Posted Oct 19, 2016 - 09:41 UTC
Investigating
At the moment 14% of Ecwid storefronts are not available. We are restoring the service now.

We are very sorry for these troubles. All your store data will be kept intact and we will be posting updates here.
Posted Oct 19, 2016 - 09:31 UTC