Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid Admin Panel: Amazon tab is not opening for non-US countries
Incident Report for Ecwid
Resolved
The issue has been resolved. Now the Amazon tab is opening for all merchants.
Posted May 30, 2020 - 06:50 UTC
Update
We have identified the source of the issue and are working on the fix. It affects merchants who are not located in the US or Canada.
Posted May 30, 2020 - 06:41 UTC
Update
We are continuing to investigate this issue. Thank you for your understanding!
Posted May 30, 2020 - 06:17 UTC
Investigating
At the moment Amazon tab (Ecwid Admin Panel > Other Channels > Amazon) is not opening for about 66% users who use native Amazon integration.

This tab is opening for users who use the Codisto app to sell on Amazon.

We are working on fixing this issue.

All your data and store settings will be intact.

We are sorry for this downtime. Next update in 30 minutes.
Posted May 30, 2020 - 04:58 UTC
This incident affected: Admin.