Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

"Sorry, the image cannot be uploaded" error message uploading product images
Incident Report for Ecwid
Resolved
This issue has been resolved.
Posted Sep 20, 2019 - 21:18 UTC
Monitoring
We found the source of the issue and implemented a fix.

Now you can upload images to your products.

We are monitoring the systems to ensure that everything works smoothly.

We are sorry about this issue.
Posted Sep 20, 2019 - 20:21 UTC
Investigating
Ecwid is having issues uploading new images to the product gallery.

When you try to add new product images in your Ecwid Control Panel > Catalog > Products, you may see an error message "Sorry, the image cannot be uploaded. Please contact our customer support team for assistance."

We're urgently working on the fix. We'll be posting updates here.
Posted Sep 20, 2019 - 19:58 UTC
This incident affected: Admin.