Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Storefronts do not display for US Ecwid merchants
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted Oct 06, 2018 - 10:37 UTC
Monitoring
The fix has been implemented. All Ecwid Storefronts display with no errors, however, we are still monitoring the process and working to make sure that the issue won't happen again.

Stay tuned.
Posted Oct 06, 2018 - 10:03 UTC
Investigating
The issue affects the storefronts on the Starter Sites and those added on the websites. All the products and store data is safe. The issue is connected with displaying them.

Our developers are working on a fix.

Please, accept our apologies for the downtime.

ETA: 1 hour
Posted Oct 06, 2018 - 09:19 UTC
This incident affected: Storefront.