Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Occasionally Ecwid storefronts, control panels, and Clover payment gateway are not loading
Incident Report for Ecwid
Resolved
This incident has been resolved.
The Ecwid servers keep functioning properly.
Posted May 11, 2020 - 06:49 UTC
Update
We've implemented one more fix for this issue and keep monitoring the results.

Next update in 1 hour.
Posted May 11, 2020 - 04:15 UTC
Update
The issue still persists, so we keep working on the fix.

All your data is safe and intact, the stores will be operating normally as soon as the issue is fixed.

Next update in 30 minutes.
Posted May 11, 2020 - 03:29 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 11, 2020 - 03:08 UTC
Update
We are continuing to work on a fix for this issue. The new ETA is 40 minutes.
Posted May 11, 2020 - 02:22 UTC
Update
We’re still on the issue working for a fix. The new ETA is 30 minutes.
Posted May 11, 2020 - 01:31 UTC
Identified
We are having issues with the servers: Ecwid control panels, storefronts, and Clover payment gateway. These servers are not loading periodically for all users. We've identified a source of the issue and now we are working on the fix.

All your data is safe and intact, the stores will be operating normally as soon as the issue is fixed.

We are sorry for this downtime. Next update in 30 minutes.
Posted May 11, 2020 - 00:52 UTC
This incident affected: Storefront and Admin.