Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Product images are not uploading
Incident Report for Ecwid
Resolved
Our developers have fixed the issue – the images are uploading fine for all users.

We are sorry for this trouble. All store data is intact.
Posted May 16, 2018 - 15:12 UTC
Investigating
At the moment all of the customers are having a problem with uploading product images (main image and gallery).

On attempt to upload product or gallery images in Ecwid control panel there is an error "Sorry, the image cannot be uploaded. Please contact our customer support team for assistance."

Our engineers are working on the fix right now.

All your store data is safe and intact.

Please accept our apologies for this issue. We will be posting updates here.
Posted May 16, 2018 - 15:02 UTC
This incident affected: Admin.