Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Instant Site is not loading
Incident Report for Ecwid
Resolved
The problem has been fixed.

Ecwid Instant sites are up and running.

All data (products, orders, your store settings, etc) are intact. Your Ecwid stores continue functioning as usual.

Thank you for your patience. Again, we deeply apologize for this situation. We will be conducting research to understand why the issue took place and how we can avoid it in the future.
Posted May 30, 2020 - 02:03 UTC
Monitoring
We keep monitoring the situation.
Posted May 30, 2020 - 00:42 UTC
Identified
The issue has been identified and fix is being implemented. Now the Instant sites should work for all the stores.

We keep monitoring the situation.

Next update in 1 hour.
Posted May 30, 2020 - 00:40 UTC
Update
We continue working on the problem.

Please, note: all your data is safe and intact.

Next update in 30 minutes.
Posted May 30, 2020 - 00:27 UTC
Update
We are continuing to investigate this issue.
Posted May 29, 2020 - 23:37 UTC
Update
We’re still working on fixing the problem. We’ll come up with an update in 15 minutes.
Posted May 29, 2020 - 23:25 UTC
Update
We’re still working on fixing the problem. We’ll come up with an update shortly.
Posted May 29, 2020 - 23:09 UTC
Investigating
We are having issue with one of our servers: Instant site is not loading for all the stores now.

We are on it and urgently looking for a fix.

All your data is safe and intact, the stores will be operating normally as soon as the issue is fixed.
We are sorry for this downtime. Next update in 10 minutes.
Posted May 29, 2020 - 22:56 UTC
This incident affected: Storefront.