Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid storefronts are sporadically not available for the users
Incident Report for Ecwid
Resolved
The problem has been resolved. All your Ecwid data is intact and everything is back to normal.
Posted Apr 19, 2019 - 02:37 UTC
Monitoring
Our development team has found the source of this issue and implemented a fix. The storefront performance is improving right now.

We are still closely monitoring the results.
Posted Apr 18, 2019 - 21:54 UTC
Identified
At the moment Ecwid storefronts are sporadically not available for the users. Our development team has found the source of this issue and is in the process of restoring the service.

Estimated time of completing the restoration is 25 minutes.

Please accept our sincere apologies. All your store data will be kept intact and we will be posting updates here.
Posted Apr 18, 2019 - 21:09 UTC
This incident affected: Storefront and Checkout.