Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid stores do not display on Weebly websites if added with a plugin
Incident Report for Ecwid
Resolved
The issue with Ecwid plugin for Weebly has been fixed.

The new Ecwid plugin version for Weebly site has been reviewed and released.

To make sure the store appears correctly on your Weebly site, please follow the steps to update the plugin:

1. Go to https://www.weebly.com/home/. 

2. Delete the embed code for an Ecwid store if you have it added. 

3. Add Ecwid with a plugin instead. It should look like this: http://take.ms/r103E 
(Here is an instruction on how to add it: https://support.ecwid.com/hc/en-us/articles/207099909-Weebly#Installation). 

4. Click the "Edit Site" button. 

5. Click "Publish".

It will reset your plugin settings, the store will show both on desktop and mobile devices. Note, that your store data stays safe and intact.
Posted Sep 11, 2018 - 13:23 UTC
Monitoring
The new Ecwid plugin version that should help to display Ecwid stores on Weebly as normal has been released and reviewed. Please, follow the steps to update the plugin:

1. Go to https://www.weebly.com/home/.
2. Delete the embed code for an Ecwid store if you have it added.
2. Make sure you have an Ecwid store added with a plugin. It should look like this: http://take.ms/r103E (Here is an instruction on how to add it: https://support.ecwid.com/hc/en-us/articles/207099909-Weebly#Installation).
3. Click on "Edit Site" button.
4. Click on "Publish".

It should reset your Ecwid plugin making it shows up on both desktop and mobile. Note, your store data will stay safe and intact.

We're very sorry about this experience. At the moment, we continue working on the investigation of it with Weebly team and we will surely take necessary measures to prevent such issues in the future.
Posted Sep 10, 2018 - 21:59 UTC
Update
We continue to communicate with Weebly support team investigating the reasons for the issue and creating the fix. By now, we have uploaded a new version of Ecwid plugin for Weebly and at the moment it is under Weebly review. The new plugin version may fix the problem and as soon as it is reviewed we will be able to see if the issue is solved. We will keep you posted on the results.

Meanwhile, you can add your Ecwid store to your Weebly website with the integration code, a piece of JavaScript code, that you need to embed into the page, where you want your Ecwid store to appear. You can generate the code for your store here — https://support.ecwid.com/hc/en-us/articles/207359989-Adding-your-store-to-any-website#GenerateCode . Once the code is added, your store will appear on the needed page.

If you don’t know how to add custom JavaScript codes to Weebly, please, refer to this article — https://hc.weebly.com/hc/en-us/articles/201740213-Create-Widgets-Embed-Code-and-Add-External-Content

Please note, your store data is safe and the issue only affects the display of Ecwid stores added with a plugin on websites built on Weebly.

We will keep you updated on any news related to the case.
Posted Sep 10, 2018 - 08:12 UTC
Update
We continue investigating the issue. Most likely, the issue is caused by some technical problems on Weebly’s end. We are currently in contact with Weebly and they are checking their backend to find the source of the problem.

As a possible solution, you may try to republish your Weebly website. This might fix the problem. In order to republish your website, click the “Publish” button in the top right corner of your Weebly site editor.

If that doesn’t help, you can add Ecwid store to your Weebly website with the the so-called “integration code”, a piece of JavaScript code, that you can embed into the page, where you want your Ecwid store to appear. You can generate the code for your store here — https://support.ecwid.com/hc/en-us/articles/207359989-Adding-your-store-to-any-website#GenerateCode . Once the code is added, your store will appear on the needed page.

If you don’t know how to add custom JavaScript codes to Weebly, please, refer to this article — https://hc.weebly.com/hc/en-us/articles/201740213-Create-Widgets-Embed-Code-and-Add-External-Content

All your store data is safe and intact. The problem only affects the displaying of Ecwid stores added with a plugin on websites built on Weebly.

We will keep you updated with the investigation.
Posted Sep 05, 2018 - 09:31 UTC
Investigating
The issue affects those merchants who added Ecwid plugin to a Weebly website. Ecwid might not display on a page on your website.
While this problem exists, consider adding Ecwid with an embed code. You can generate it here: https://support.ecwid.com/hc/en-us/articles/207359989-Adding-your-store-to-any-website#GenerateCode
We are working with Weebly to get the issue resolved. We will keep you updated.
Note: the issue does not anyhow affect the stores' data (orders, products, customers etc) — all your data is safe. The problem only affects the displaying of Ecwid stores added with a plugin on websites built on Weebly.
Posted Sep 04, 2018 - 21:31 UTC
This incident affected: Storefront.