Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Some Ecwid control panels and storefronts are unavailable
Incident Report for Ecwid
Resolved
Our engineers have released a fix and now all the Ecwid control panels and storefronts are operational.

All merchants can access their dashboards, all customers can browse stores and place orders.

Thank you for your patience!
Posted Oct 31, 2019 - 05:11 UTC
Investigating
27% of Ecwid control panels and storefronts are not loading:
You may see the 'We are having technical issues' error in your control panel. And your customers can not access your store.

We are urgently working on a fix.

All your data (products, orders, customer details, store settings, etc) is safe and intact. The control panels and storefronts will be up and running once we fix the problem.

We are very sorry for this downtime. We’ll be posting updates regularly.

If you have any questions, you can email our Support team at support@ecwid.com, or start Pre-Sales Chat: click on the chat icon on our site https://www.ecwid.com/
Posted Oct 31, 2019 - 04:32 UTC
This incident affected: Storefront, Checkout, Admin, API, Third-party services, and Billing.