Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Square payment option cannot be set up
Incident Report for Ecwid
Resolved
Our developers checked the system and found out that the issue was on the Square side. The error doesn't display anymore and the Square payment method can be connected with no issues.
Posted Sep 19, 2019 - 16:12 UTC
Investigating
At the moment Ecwid merchants cannot connect the Square payment option.

After they go to Ecwid Control panel > Payments > Square and click "Connect and Enable Square" they see an error message: Problem accessing /ecwid/connect. Server error.

We are on it and urgently looking for a fix.
All your data is safe and intact, the stores will be operating normally as soon as the issue is fixed.

In the meantime, please, consider using any other payment methods. You can see the list of them here: https://support.ecwid.com/hc/en-us/articles/360003449720-Payment-options-by-countries

We are sorry for this. Next update on the issue in 30 minutes.
Posted Sep 19, 2019 - 15:54 UTC
This incident affected: Checkout.