Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Order pages are not loading on Ecwid Dashboards
Incident Report for Ecwid
Resolved
We are glad to inform you that the issue has been fixed. All the data (products, orders, your store settings, etc) are safe and intact. The Order Page in Ecwid dashboard continues functioning as usual. We are deeply sorry for the difficulties you faced.
Posted Oct 01, 2019 - 19:40 UTC
Monitoring
A fix has been implemented. We continue to monitor the systems to ensure that everything works smoothly.
Posted Oct 01, 2019 - 19:04 UTC
Investigating
We are experiencing an issue with one of the servers — Order Pages on Ecwid Dashboards load slowly or don't load at all. You may see 'We are having technical difficulties' error.

We are urgently looking into the issue.

All your data (products, orders, customer details, store settings, etc) is safe and intact. Order pages on Ecwid Dashboards will be up when the issue is fixed.

We are sorry for this downtime.

If you have any questions you can reach our Support team via email at support@ecwid.com. Premium users can contact us via Live Chat from Ecwid Dashboard > Get Help > Open Live Chat.
Posted Oct 01, 2019 - 18:41 UTC
This incident affected: Admin.