Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Import products function is unavailable for 15% of Ecwid users
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted Oct 05, 2018 - 14:37 UTC
Investigating
Right now 15% of Ecwid users cannot import their products. We are investigating the problem.

All your data will be kept intact and safe. Please, accept our apologies for this downtime. We will inform you of the progress here.
Posted Oct 05, 2018 - 14:03 UTC