Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Storefronts load slowly or do not load.
Incident Report for Ecwid
Resolved
The issue has been sucessfully resolved. At the moment all the systems are up an running. Ecwid storefronts and Control Panels load as per normal.

To those affected, we are truly sorry for this. Thank you for your patience and understanding.
Posted Sep 28, 2018 - 10:40 UTC
Investigating
Some of the Ecwid storefronts load slowly or do not load. The problem affects the storefront display. Rest assured that all data is safe and intact.
Ecwid developers are looking for the reason for this downtime.

Check this page for updates.

Please accept our sincere apologies.
Posted Sep 28, 2018 - 09:51 UTC
This incident affected: Storefront, Checkout, Admin, API, Third-party services, and Billing.