Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid Instant Sites are unavailable
Incident Report for Ecwid
Resolved
We are glad to inform you that the issue has been resolved. All the data (products, orders, your store settings, etc) are safe and intact. The Ecwid Instant Sites continue functioning as usual. We apologize for the temporary difficulties caused by this issue.
Posted Aug 29, 2019 - 14:45 UTC
Monitoring
Our developers implemented the fix. We continue to monitor this issue.
Posted Aug 29, 2019 - 14:30 UTC
Investigating
We are having issues with all of Ecwid Instant Sites: they are unavailable for 100% of users. We are working to bring Ecwid Instant Sites back into service.

All your data (products, orders, customer details, store settings, etc) is safe and intact, the Instant Sites will be operating normally as soon as the issue is fixed.
We are sorry for this downtime. Next update on the issue in 20 minutes.
Posted Aug 29, 2019 - 14:09 UTC
This incident affected: Storefront.