Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid stores not available on the Wix websites
Incident Report for Ecwid
Resolved
We are glad to let you know that all the Ecwid servers are up and running. Ecwid storefronts are fully operational and display with no issues.

We’re really sorry to be holding you up today!  Thanks again for your patience.
Posted Oct 06, 2018 - 10:38 UTC
Monitoring
The fix has been implemented and at the moment our developers are monitoring the systems.
Right now the Wix stores display as per normal and merchants can access the Ecwid app on the Wix websites.
Posted Oct 06, 2018 - 08:39 UTC
Investigating
Ecwid merchants whose stores are added to Wix websites might have issues with accessing the dashboard and the store itself. Our developers are working on a fix.
In the meantime, merchants can access the control panel directly at https://my.ecwid.com
ETA: 1 hour

All your data will be kept intact and safe. Please, accept our apologies for this downtime. We will inform you of the progress here
Posted Oct 06, 2018 - 08:17 UTC
This incident affected: Storefront.