Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Issues with loading of product catalogs in Control Panels
Incident Report for Ecwid
Resolved
Our developers have fixed the issue and all product catalogs load as normal now in Ecwid Dashboards.

All the data (products, orders, your store settings, etc) are safe and intact. The Ecwid stores continue functioning as usual.

We'd like to apologize for the temporary difficulties caused by this issue.
Posted Feb 14, 2019 - 21:55 UTC
Identified
Our developers have identified the cause of the issue, and we are rolling out a fix. ETA is 2 hours.

We'll keep you posted.
Posted Feb 14, 2019 - 19:14 UTC
Investigating
Users with large catalogs (with more than 100 products) may experience issues accessing their catalog pages in Ecwid dashboards — they are loading slowly or don't load at all. Other areas of the dashboard can be opened without a problem.

Our developers are already aware of the issue, we are looking into it now.

Don't worry — your store and product data is safe. We'll be posting updates here.
Posted Feb 14, 2019 - 18:17 UTC
This incident affected: Admin.