Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Built-in payment forms don't load at the checkout.
Incident Report for Ecwid
Resolved
We've identified and fixed the problem.
Customers can place orders in your stores and pay online using Stripe, Square, Clover, Payeeze, WePay and other payment providers normally.

All your information is safe and intact.
Posted Jun 10, 2020 - 05:24 UTC
Investigating
We're having issues with built-in payment forms at the checkout. Customers cannot currently complete a purchase using Stripe, Square, Clover, Payeezy and WePay payment methods.

Our developers are investigating it now. We're very sorry for that.

For now, we suggest enabling another payment method in your store to accept payments from your customers.

The next update will be in 20 minutes.
Posted Jun 10, 2020 - 05:02 UTC
This incident affected: Checkout.