Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid Instant Sites are not loading
Incident Report for Ecwid
Resolved
We are glad to inform you that the issue has been resolved. All the data (products, orders, your store settings, etc) are safe and intact. The Ecwid Instant site and stores continue functioning as usual. We are deeply sorry for this downtime.
Posted Nov 29, 2019 - 01:35 UTC
Monitoring
A fix has been implemented. Instant Sites load as normal now.

We continue to monitor the systems to ensure that everything works correctly.
Posted Nov 29, 2019 - 00:54 UTC
Investigating
We are having issues with all of Ecwid Instant Sites — they are not loading. We’re working on it urgently and will keep you posted here.

All your data (products, orders, customer details, store settings, etc) is safe and intact. The Instant Sites will be up and running as usual once the issue is fixed.

We are sorry for this downtime. The next update is in 15 minutes.

If you have any questions you can reach our Support team via email at support@ecwid.com. Premium users can contact us via Live Chat from Ecwid Dashboard > Get Help > Open Live Chat ( Screenshot ).
Posted Nov 29, 2019 - 00:40 UTC
This incident affected: Storefront.