Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Issue with upgrading to a paid plan.
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted Sep 14, 2018 - 07:57 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 14, 2018 - 06:11 UTC
Update
We are continuing to investigate this issue.
Posted Sep 14, 2018 - 05:51 UTC
Investigating
Some of the Ecwid merchants might have an issue while upgrading to any of the paid plans.

The problem manifests itself if you upgrade with a credit/debit card. The entered payment details can’t be saved.

For the first time upgraders there is still an option to upgrade with PayPal. PayPal account details can be entered after the Billing and Plans page reload.

For those who upgrade to a higher plan, you can still upgrade with the already added credit/debit card or with your PayPal account.

The problem doesn’t affect your current subscriptions. All the subscriptions and payment details are save and intact.

Our team is investigating the issue. We’re working to resolve this situation as quickly as possible.

Please, accept our apologies for this downtime. Your patience is truly appreciated.
Posted Sep 14, 2018 - 05:28 UTC
This incident affected: Billing.