Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid storefronts and control panels are unavailable
Incident Report for Ecwid
Resolved
This issue has been resolved.
Posted Sep 15, 2019 - 16:05 UTC
Monitoring
A fix has been implemented and now you Ecwid storefronts and control panels loads normally — you can access your Ecwid control panel without any issues and your stores can accept orders as usual.

We are monitoring the systems to ensure that everything works smoothly.
Posted Sep 15, 2019 - 14:47 UTC
Investigating
We are having issues with the servers: Ecwid control panels and storefronts are not loading for 100% of users. We are working to bring Ecwid storefronts and control panels back into service.

All your data (products, orders, customer details, store settings, etc) is safe and intact, the storefronts and control panels will be up and running when we fix the issue.

In case you have any questions feel free to reach our Support team via email at support@ecwid.com.

We are sorry for this downtime. Next update on the issue in 15 minutes.
Posted Sep 15, 2019 - 14:22 UTC
This incident affected: Storefront, Checkout, Admin, and API.